• Club Store - 10% off now through Black Friday
    Use discount code BF10 at checkout. --> HondaSxS Club Store
BOX1

BRed 2013 MUV700 Hard Start, Stalling & Missing Issues

Kelster

New Member
Apr 19, 2015
2
0
1
Hey Folks,
Our 2013 Big Red is having intermittent issues. We use it every day on the farm so it's super important that it be operating.

It seems to start OK when cold but will barely turn-over when Hot, then it smells like it's running rich (fuel smell). After running for a half-hour under load it will Stall and be hard to re-start.

I can hear the fuel pump prime when turning the key, but I'm not sure it's priming the way it should.

When I open it up, it will Miss at high RPM and does not shift properly. Might not be getting enough fuel. I can't seem to find a Fuel Filter anywhere in the exploded parts diagrams, but I think the fuel tank must be removed to pull the Pump / Sending unit - correct? Do I need the special tool to remove the sending unit, as shown in the service manual??

Any thoughts or suggestions would be greatly appreciated. Thanks Y'all.
 
BOX2
box3

About us

  • Our community has been around for many years and pride ourselves on offering unbiased, critical discussion among people of all different backgrounds. We are working every day to make sure our community is one of the best.

User Menu

Buy us a beer!

  • Lots of time and money has gone into making sure the community is running the best software, best designs, and all the other bells and whistles. Care to buy us a beer? We'd really appreciate it!

    Beer Fund!