• Welcome to HONDASXS.com

    If you are a guest please take time to REGISTER with us. Stay up to date on the Honda Side by Side line and take part in our online forum. Check out the FAQ. Once you register you can start to make post. Users will respond to your question or statement. To start viewing messages, select the forum that you want to visit below or click the board index to see a list of all forums. Thanks and have fun.

P1000m5 Steering getting stiff

Discussion in 'General Discussion' started by Stephen_Lancaster, Jun 16, 2019.

  1. Stephen_Lancaster

    Stephen_Lancaster New Member

    Joined:
    Jun 16, 2019
    Messages:
    3
    Likes Received:
    0
    Location:
    Waterproof Louisiana
    Ownership:
    1000-5
    I have a Pioneer 1000-5 and the steering seems to be much stiffer than normal. Does this unit have power steering or is this just normal after 1 year of use,? It is a 2018 model
     
  2. BigOL3

    BigOL3 Well-Known Member

    Joined:
    Oct 27, 2017
    Messages:
    1,166
    Likes Received:
    2,214
    Location:
    Deep in the heart of Dixie, Kentwood, La.
    Ownership:
    1000-5
    If it has becoming harder to steer, sounds like you may have lost EPS.
     
  3. Stephen_Lancaster

    Stephen_Lancaster New Member

    Joined:
    Jun 16, 2019
    Messages:
    3
    Likes Received:
    0
    Location:
    Waterproof Louisiana
    Ownership:
    1000-5
    Thanks for the reply, is that a take to the dealership fix or something I can do myself,, Is there possibly a fuse blown or something similar
     
  4. BigOL3

    BigOL3 Well-Known Member

    Joined:
    Oct 27, 2017
    Messages:
    1,166
    Likes Received:
    2,214
    Location:
    Deep in the heart of Dixie, Kentwood, La.
    Ownership:
    1000-5
    Have to let someone else more knowledge chime in later. I have no first hand knowledge on the EPS, but could be a fuse.
     
  5. Adam490

    Adam490 Well-Known Member
    Lifetime Member

    Joined:
    Apr 7, 2019
    Messages:
    164
    Likes Received:
    513
    Location:
    Covington, LA
    Ownership:
    1000-5
    This might be a stupid question, but have you checked the plugs/connectors for the EPS? If you ride through a bunch of deep mud you might have a bunch of crap built up in the universals also.
     
  6. Stephen_Lancaster

    Stephen_Lancaster New Member

    Joined:
    Jun 16, 2019
    Messages:
    3
    Likes Received:
    0
    Location:
    Waterproof Louisiana
    Ownership:
    1000-5
    Thanks for the reply, No I haven't checked the plugs or connectors because I don't know where they are located,, also are universals the same as connectors or something, different,,
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
Loading...